aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Halase <jordan@halase.me>2019-09-30 12:30:24 -0500
committerJordan Halase <jordan@halase.me>2019-09-30 12:30:24 -0500
commitc28b5a398520b71ea95f3160de29f59183dd3433 (patch)
treeefe7320d4308b04d93cebe56b0944761a76e8a3f /CMakeLists.txt
parentdd0bc299e39e1afb8acfd34698d6bea8f9df8587 (diff)
Build with CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..89a43d3
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,7 @@
+cmake_minimum_required(VERSION 2.6)
+project(Asteroids)
+
+find_package(SDL2 REQUIRED)
+include_directories(${SDL2_INCLUDE_DIRS})
+add_executable(Asteroids main.c)
+target_link_libraries(Asteroids ${SDL2_LIBRARIES} m)