aboutsummaryrefslogtreecommitdiff
path: root/test
AgeCommit message (Collapse)Author
2020-10-14Suppress IWYU warnings in build testsDavid Robillard
2020-10-04Add refresh rate hintDavid Robillard
2020-10-04Print all view hints in shader demo and hint testsDavid Robillard
2020-10-04Add puglGetViewHint()David Robillard
This allows retrieving properties of the view that may be needed, such as the actual bit depth (which may vary from the suggested depth provided as a hint).
2020-07-05Improve struct packingDavid Robillard
Unfortunately there is no warning like Wpadded but only for internal padding, so that can't be turned on, but if there was, after this commit the build would be clean with it. Maybe some day...
2020-07-05Ensure that all API headers are warning-freeDavid Robillard
2020-07-05Add scroll direction fieldDavid Robillard
2020-07-05Print crossing mode of enter and leave eventsDavid Robillard
2020-07-05Replace grab flag in PuglEventFocus with crossing modeDavid Robillard
2020-07-02Fix cast alignment warnings on 32-bit ARMDavid Robillard
2020-05-16Add default and maximum sizeDavid Robillard
2020-05-16Use email address in copyright headersDavid Robillard
Not really sure why I used a web link here (maybe because it's more stable), but this is more conventional.
2020-05-16Fix redisplay test on MacOSDavid Robillard
This does two things: posts the redisplay when an update event is received (which is correct pattern for this now), and uses larger even numbers for the redisplay region so they make it through the pixel/point conversion process without loss.
2020-05-16Make show/hide test tolerant to multiple exposuresDavid Robillard
This happens on MacOS.
2020-04-04Fix mismatched printf parameter warningDavid Robillard
Compilers are allowed to choose signed or unsigned for enums, and apparently gcc and c++ make different choices.
2020-04-01Replace puglShowWindow() with puglRealize()David Robillard
2020-03-31Add format attribute to logError()David Robillard
2020-03-31Fix mismatched printf parameter typesDavid Robillard
2020-03-17Use clearer names for pointer eventsDavid Robillard
These old "notify" names are a smell from X11 which is a bit strange and inconsistent here, since nearly everything is a "notification" of sorts. I think the new names here are much more clear since they are consistent with the keyboard focus events.
2020-03-16Cleanup: Add missing includesDavid Robillard
2020-03-16Add timer eventsDavid Robillard
2020-03-16Make update test more tolerantDavid Robillard
2020-03-15Cleanup: Fix stale commentDavid Robillard
2020-03-15Unify event loop functions as puglUpdate()David Robillard
The previous separation between polling and dispatching was a lie, especially on MacOS where it is impossible to only poll for events without dispatching anything. Providing such an API is misleading, and problematic in various other ways. So, merge them into a single puglUpdate() function which can do the right thing on all platforms. This also adds the behaviour of actually processing all events in the given time interval, which is almost always what clients actually want to do when using a positive timeout (naively doing this before caused terrible input lag).
2020-03-15Add type and flags to worldDavid Robillard
Unfortunately this is an API break, but there's no reasonable way to deprecate the old function and this is required for things to work correctly. The type will be used in following commits to tick the main loop and dispatch events correctly for either case.
2020-03-15Cleanup: Fix indentationDavid Robillard
2020-03-09Add test for redisplays posted in the event loopDavid Robillard
2020-03-09Add PuglEventClient and puglSendEvent()David Robillard
This event makes it possible to send an arbitrary event to a view, which is useful for many things. In particular, this method of communication with views will wake up the event loop, unlike hacks in applications that share data in some other way.
2020-03-09Add test for basic view creation, exposure, and destructionDavid Robillard
2020-03-09Add create, destroy, map, and unmap eventsDavid Robillard
These can be used to do things when a view is created or destroyed, in particular set up the GL context in a more controlled way. Map and unmap events are also added for when views are shown and hidden so application can react to this as well. Towards the deprecation of puglEnterContext() and puglLeaveContext(), which are prone to abuse. squash! Remove client event stuff
2020-03-08Enable double buffering by defaultDavid Robillard
2020-03-08Add vsync command line options to demosDavid Robillard
2020-03-08Move demo programs to examples directoryDavid Robillard
These are not really tests, but examples or demos, which has caused some confusion in the past. So, move them, and make room for actual tests.
2020-03-08Split graphical utilities out from test_utils.hDavid Robillard
2020-03-08Print when unknown events are received in testsDavid Robillard
2020-03-08Cleanup: Fix some conversion warningsDavid Robillard
2020-03-07Test: Don't reuse cube vertices for backgroundDavid Robillard
This was pretty confusing since it looked like the parent view was drawing the cube as well, and inefficient since only a single rect needs to be drawn here.
2020-03-07Test: Fix cube rotation via mouseDavid Robillard
2020-03-02Strengthen ultra-strict warnings with clangDavid Robillard
2020-03-01Cleanup: Adjust some code to be more clang-format friendlyDavid Robillard
2020-03-01Cleanup: Shorten event printing codeDavid Robillard
2020-03-01Cleanup: Fix includesDavid Robillard
2020-02-18Cairo Test: Preserve clip rectangle for background fillDavid Robillard
2019-12-11GL3 Test: Use instancingDavid Robillard
2019-12-11GL3 Test: Update bindings to OpenGL 3.3David Robillard
2019-12-11GL3 Test: Spread out rectangles moreDavid Robillard
2019-12-11GL3 Test: Calculate border color on the GPUDavid Robillard
2019-12-11GL3 Test: Move shaders to separate filesDavid Robillard
2019-12-09Fix use of incorrect union elementDavid Robillard
2019-11-21Rename "backend" headersDavid Robillard
Working on Vulkan clarified what has always been slightly smelly about the design and organization here: not everything that is API specific is really in a "backend" (a PuglBackend). The concrete example is puglGetProcAddress(), which only makes sense for GL and is actually implemented in the "backend" files. Arguably puglGetContext() is also such a thing. So, rename the headers so they can be the place where API-specific things go in general, which happens to include a backend most of the time. The stub is a bit of an exception to this, but whatever. The includes look tidier this way. In place of the old headers are compatibility stubs that just emit a warning and include the new version, which will be maintained for a while.